Codice

Per richiedere il codice, compilare il modulo online oppure scaricarlo da : https://github.com/GruppoMeta/Movio

I requisiti per l'installazione sono i seguenti:

Sistema operativo: Linux

Altro software necessario prima di procedere all'installazione:

  • Web Server: Apache 2.2 or newer
  • RDBMS: MySQL 5.1 or newer
  • PHP: 5.3

Estensioni PHP:

  • PDO,
  • PDO_MYSQL
  • DOM
  • LIBXML
  • JSON
  • GD Lib

Istruzioni per l'installazione:

  • creare un database movio
  • importare il dump del database che si trova in application/data/movio.sql
  • aprire il file application/config/config.xml ed inserire alle righe 6 e 7 l'username e la password del database
  • impostare i permessi in scrittura della cartella cache/
  • impostare i permessi in scrittura della cartella admin/cache/
  • impostare i permessi in scrittura della cartella application/mediaArchive
  • impostare i permessi in scrittura della cartella application/classes/userModules
  • Apache deve avere il modulo "mod_rewrite" attivo (altrimenti l'installazione va a buon fine, ma non si accede al pannello di amministrazione)
ATTENZIONE
MOVIO è un'applicazione web che necessita di un webserver. Una volta effettuata l'installazione, si può operare con qualsiasi computer.
Dopo aver realizzato una mostra, si prega di avvisare scrivendo una mail a otebac@beniculturali.it, cosi' da essere inseriti nell'elenco delle mostre realizzate con MOVIO.